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KOMEN / CADANGAN  
Sila emelkan maklumbalas / komen / cadangan anda   emel: 
admin@nexis.com.my    
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Pengenalan  

Manual panduan ini adalah rujukan untuk pembangunan laman web professional 
menggunakan aplikasi Joomla! 3.x.  Anda akan ditunjukkan cara-cara membina laman web 
Joomla! 3.x secara praktikal. Panduan dan tunjukajar lebih lengkap boleh anda perolehi 
jika menghadiri kursus Pembangunan Joomla! 3.x yang kami anjurkan.  

Namun anda boleh merujuk manual panduan ini untuk melakukan sendiri pembangunan 
Joomla! 3.x. Selamat mencuba!  

Pra Persediaan Sebelum Membina Web Joomla!  

Anda perlukan pra persediaan ini sebelum membangunkan web Joomla!  

1. Aplikasi Web Server bundle. Di dalam latihan ini kita akan menggunakan XAMPP 
versi yang menyokong versi semasa Joomla! 3.x  

2. Software Joomla! core versi terkini. Versi 3.x  

3. Aplikasi archive utility seperti 7Zip untuk mengekstrak fail.  

4. Web browser samada Firefox atau Google Chrome (tidak digalakkan menggunakan 
Internet Explorer – IE)  

Tips Belajar Joomla!  

1. Untuk memudahkan mempelajari Joomla! peringkat asas dan pertengahan, 
tajuktajuk berikut akan dipelajari:  
  

a. Memasang Joomla! di web server local  

b. Memilih Template Joomla!  

c. Membina Menu   

d. Membina Sub-Menu  

e. Memasang Extensions (Plugin, Modul, Template, Language, 
Components)  

f. Memasukkan Gambar, Video. Audio ke dalam Artikel  

g. Memasang / Install Template  

h. Keselamatan Joomla!  

i. Backup dan Restore  

j. Memasang Joomla! di server Internet  
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2. Sekiranya anda dapat menggunakan perkara di atas, bermakna anda sudah boleh 
membina laman web Joomla! anda sendiri. Kita akan mempelajari tajuk ini di dalam 
kelas.  

    
Memasang Perisian XAMPP  

1. Perisian XAMPP adalah satu pakej bundle perisian yang mengandungi:  

a. Apache -  web server  

b. MySQL – pangkalan data (database)  

c. PHP – script pengaturcaraan  

d. Perl - script pengaturcaraan  

e. X – cross platform (dimana ianya boleh digunakan untuk pelbagai OS 
seperti  
Windows, Linux, Mac dsbnya)  
  

2. Untuk mendapatkan perisian ini, anda boleh download di web rasmi iaitu 
www.apachefriends.org   
  

3. Install fail yang telah di download ke dalam PC anda.  
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Tunggu sehingga proses installation selesai.  
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Pastikan kedua-dua status Apache dan MySQL di bawah berwarna hijau (menandakan 
ianya running)  
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4. Anda perlu menguji cuba aplikasi XAMPP yang diinstal. Buka web browser dan 
taipkan localhost pada URL web browser.   
  

 
Paparan seperti di atas akan diperolehi. Ini bermakna web server anda berfungsi 
dengan baik. Klik pada English.   
  
Nota: Web server Apache atau MySQL database berkemungkinan tidak dapat di 
runkan atas beberapa sebab:  
  

a. Port 80 telah digunakan oleh aplikasi lain seperti terdapat Skype, web server 
lain seperti IIS yang telah secara otomatik run terlebih dahulu.  
  

b. Oleh itu anda boleh mematikan services tersebut atau tick pada Service di 
dalam XAMPP Control Panel tersebut dan restart PC untuk ianya otomatik 
run.  
  

    

Meletakkan Fail Joomla! Core di dalam Web Server  

  
Fail Joomla! core yang telah didownload dari web Joomla.org perlu diletakkan di dalam 
fail web server.  

Oleh kerana kita menggunakan XAMPP, dan lokasi XAMPP adalah di C, maka kita perlu 
mencari lokasi XAMPP tersebut dan dapatkan folder yang bernama htdocs.  

Letakkan fail Joomla! core tersebut di dalam folder htdocs.  

Contoh:  localhost    ( semua huruf kecil )   
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Extract file tersebut menggunakan 7zip (atau program archive utility lain seperti WinZip 
dll) Pastikan extract ke dalam folder Joomla! core supaya fail tersebut terkumpul di 
dalamnya.  

  

  
  



 

11  

  

 

Rename folder yang telah diunzip. Rename kepada sebarang nama. Dicadangkan nama 
laman web yang dibina. Contoh latihan3  
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Fail Joomla! core latihan3 tersebut sedia untuk diinstall. Langkah seterusnya ialah 
menginstal fail Joomla! core tersebut.   

    

Menginstall Joomla! 3.x  

1. Untuk melakukan installation Joomla!, buka web browser dan taipkan 
localhost/<namafolder >  
  
Contoh: localhost/latihan3  
  

2. Paparan di bawah akan diperolehi. Main Configuration. Sila isikan mengikut ruangan 
di bawah.  
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3. Seterusnya paparan berikut akan diperolehi. Database Configuration.  
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4. Seterusnya paparan berikut akan diperolehi. Finalisation. Klik pada Install Sample 
Data > Brochure English untuk tujuan melihat contoh paparan web.  

 

    
  

5. Pastikan semua ruangan parameter warna hijau. Ini menunjukkan semua parameter 
dalam keadaan sempurna.  
  

  

Taipkan  root   

Kosongkan   

Taipkan sama dengan  
nama folder laman web  
iaitu  latihan3   
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6. Proses installation sedang berjalan. Sila tunggu hingga selesai.  

  
  
  
  
  

7. Proses installation selesai. Klik pada Remove installation folder. Dan klik pada Site.  
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8. Laman Web Joomla! telah diperolehi seperti di bawah.  
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3 Rahsia Belajar Joomla! Cara Kacang Dibongkar  

1. Dari pengalaman saya, ramai yang mengatakan apabila menggunakan Joomla! ianya 
terlalu sukar kerana banyak perkara perlu dipelajari. Sebenarnya TIDAK jika anda 
mengetahui rahsianya bawah ini.  
  
Belajar Joomla! sangatlah mudah! Bagi memudahkan pembelajaran Joomla!  3 
formula rahsia yang saya cipta akan digunakan.   
  

2. 3 formula tersebut adalah:  

a. Menu  

b. Modul  

c. Artikel  
  

3. Anda perlu memahami ketiga-tiga perkara ini. Asasnya mana-mana laman web 
Joomla! tidak kira apa versi sekalipun (samada 2.5 atau 3.x) mempunyai 3 perkara ini. 
Tidak kira secanggih mana laman web tersebut, ketiga-tiga perkara ini terdapat di 
dalam web Joomla! tersebut.  
  
Saya jamin jika anda dapat memahami 3 perkara ini maka sangat mudah bagi anda 
menguasai Joomla!  
  

4. Apakah yang dimaksudkan dengan 3 formula tersebut? Saya akan tunjukkan dan 
terangkan berdasarkan kepada rajah di bawah.  
  

    
5. Rajah sebuah laman web Joomla! (secara umumnya) yang mengandungi Menu,  

Module dan Article  
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6. Latihan mengenal pasti Menu, Module dan Article  
  
Merujuk kepada penerangan yang diberikan, dimanakah yang dimaksudkan:  
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a. Menu?  

b. Module?  

c. Article?  

di dalam laman web latihan di atas?  
  

7. Sila buktikan.  
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Back-End dan Front-End  
 

1. Istilah Back-End dan Front-End sangat sinonim dengan Joomla! Apa itu Back-End dan 
Front-End?  
  

2. Back-End adalah ruangan untuk pentadbir membuat pengubahsuaian terhadap web 
Joomla!  
  
Untuk mendapatkan ruangan ini, anda perlu taipkan administrator pada penghujung 
laman web:   
  
Contohnya: localhost/latihan3/administrator  
  
Login page administrator akan diperolehi. Sila masukkan username dan password di 
ruang pentadbir Joomla! yang telah anda tetapkan semasa proses installation 
sebelum ini.  
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3. Front-End adalah paparan laman web Joomla! yang dilihat oleh pengunjung.   
  
Taipkan localhost/latihan3  
  
Paparan laman web kepada pengunjung.  

  

  

  

   
  

  
  

  

    
LANGKAH PERTAMA - Membuat System Server Settings   

 

1. Pergi ke Back-End. System > Global Configuration.  
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2. Pergi ke Server Settings  
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 Template Joomla!  
 

1. Joomla! core menyediakan template. Anda boleh melihat template yang diberikan di 
ruangan berikut:  

 
2. Site adalah Front-End. My Default Style > Default  

 
3. Terdapat hanya 2 site template (Front-End) yang diberikan di dalam Joomla! core 

iaitu Beez3 dan My Default Style.   
  

    
Menginstall Template Joomla!  

 

1. Anda boleh mencari template Joomla! yang serasi untuk diinstall di dalam Joomla!  
core anda. Template boleh didapati secara percuma atau berbayar.  
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3. Pilih Upload Package File > Choose File > Upload & Install  

 
4. Lihat di Extensions > Template Manager. Template baru telah diinstall. Klik Default.  

 
Nota: Untuk melihat Template Positions, taipkan ?tp=1 pada web browser 
frontend. Contohnya:     localhost/latihan3?tp=1   

    
  

2.   Untuk menginstall Template Joomla!, anda  perlu ke :   
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Menukar Nama Menu (Contoh: Home kepada Utama)  

1. Setelah anda melihat laman web anda, ada dipaparkan menu Home pada laman 
web. Untuk menukarkan nama menu Home kepada Utama seperti di bawah:  
  

 

  

  

  

  

  
  

2.   Pergi di  Back - End .  Menu s     > Main Menu   

  

Akan ditukar kepada  
Utama   
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3. Klik pada nama menu Home  

 

4. Tukar pada Menu Title > Buangkan Alias > Save  

 

    

Menambah Menu Baru   
  

1. Untuk membuat menu baru, Menus > Main Menu  
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3. Masukkan Menu Title contoh Perkidmatan Kami dan pilih Menu Item Type > 
Select  

 
4. Pilih Text Separator untuk menu paling atas (tiada pautan ke mana-mana)  

  
2.   Klik butang  New   
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5.   Save dan Refresh   laman web   



 

29  

  

Membuang Menu Yang Tidak Perlu  

 
  

2. Mesej berikut akan diperolehi. Menu telah dibuang di dalam Trash.  

   
3. Refresh laman web.   

    

  
1.   Pergi ke  Back - End .  Menus > Main Menu   
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Mengubah Kedudukan Menu  
  

1. Pergi ke Back-End. Menus > Main Menu  
  

2. Pergi ke nama menu yang ingin diubah. Contoh menu Perkhidmatan Kami. 
Klik pada nama menu Perkhidmatan Kami tersebut.  
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3. Refresh Laman Web  
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Membuat Sub-Menu  

1. Untuk membuat Sub-Menu, anda perlu tentukan samaada submenu tersebut 
akan memaparkan artikel atau tidak? Sekiranya submenu memanggil artikel, 
bermakna anda perlu menyiapkan artikel terlebih dahulu (sila rujuk pada tajuk 
membina artikel).  
  
Sekiranya submenu tersebut tidak memanggil artikel, bermakna artikel tidak perlu 
dibuat. Anda boleh terus membuat submenu.  
  
Dalam contoh ini, kita akan lihat bagaimana membina submenu yang akan 
memaparkan atau memanggil artikel.  
  
Contoh adalah seperti Submenu Objektif Syarikat yang akan berada di bawah menu 
Tentang Kami.  
  

2. Pergi ke Back-End. Buat dahulu artikel Objektif Syarikat (rujuk pada mukasurat 
tajuk membuat artikel baru di bawah)  
  

3. Selepas selesai membuat artikel, Pergi ke Menus > Main Menu.   
  

4. Klik New. Membuat SubMenu Objektif syarikat.   

 
Masukkan Tajuk Submenu. Contoh Objektif.   
Pilih Menu Item Type sebagai Single Article. Pilih Select Article > Objektif.  
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5. Pilih Parent Item untuk memastikan ianya menjadi Submenu. Oleh kerana 
submenu ini akan berada di bawah Tentang Kami, maka Parent Item adalah 
Tentang Kami.  

 
6. Save dan refresh laman web.    
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Membuat Artikel Baru  

 
  
  

2. Senarai artikel akan dipaparkan (sekiranya ada). Klik New untuk membuat artikel 
baru.  

 
  

3. Masukkan Tajuk Artikel, contohnya Objektif dan taipkan Isi Kandungan Artikel.  

1.   Pergi di  Back - End .  Content   >   Article Manager   
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Memasukkan Gambar ke dalam Artikel  

1. Pergi ke Back-End. Content > Article Manager   
  

2. Pilih satu artikel yang ingin dimasukkan gambar di dalamnya. Letakkan cursor pada 
ruangan teks editor.  

  

  
  

4.   Klik  Save   & Close   
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4. Klik Choose Files atau Browse dan Start Upload untuk memasukkan gambar.  

 
  
  
  

5. Klik pada gambar yang telah diupload dan Insert.  

  
  

3.   Klik  Image   ( di bawah ruangan editor )   
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6. Klik Save dan refresh laman web.  
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Memasukkan Galeri Gambar  

1. Galeri gambar ialah koleksi pelbagai gambar di dalam satu page laman web. Oleh 
kerana Joomla! core tidak mempunyai feature untuk memasukkan galeri gambar, 
maka kita perlu menggunakan Extensions.  
  

2. Anda perlu mencari Extensions galeri gambar yang sesuai. Untuk mencari extension 
yang sesuai, anda perlu pergi ke ruang Joomla! Extension Directory (JED) di web 
www.joomla.org   
  

3. Sebelum boleh menggunakan Extensions tersebut anda perlu mendownload 
extensions tersebut dari JED dan menginstall Extensions di dalam Joomla! admin. 
Cara untuk menginstall Extensions sila rujuk pada bahagian di bawah.  
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Menginstall Extensions  

1. Untuk mendapatkan Extensions, anda boleh dapatkan di JED di web joomla.org 
Extend > Extension Directory dan boleh lakukan search. Contoh taipkan image 
gallery pada ruangan search.  

 
2. Setelah mendapatkan Extensions tersebut, anda boleh menginstallkannya di 

BackEnd. Pergi ke Back-End. Extensions > Extension Manager.   

 
3. Klik pada Upload Package File tab. Choose File dan pilih fail extensions yang ingin di 

install. Selesai memilih klik Upload & Install 
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4. Tips Install Extensions ialah: a- Check samada dia tidur / bangun? b- Kalau tidur bangunkan.  

c- Jumpa dia.  
  
Tanda plugin tersebut tidur (Disable). Perlu ditukar kepada Enable  

 

 
  

Anda perlu membaca cara penggunaan plugin ini. Penerangan plugin terdapat pada 
ruang Description.  

  
5. Cara menggunakan plugin ini. Klik pada Content > Media Manager  

  

  

  
Klik pada  Simple Image Gallery   
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6. Buatkan folder. Create New Folder.  

 
  

8. Klik Upload. Masukkan gambar-gambar di dalam folder jtc1 tersebut  
  

  

  
  
  

  
7.   Klik pada folder   jtc1 .     
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9. Setelah gambar dimasukkan, pergi ke artikel dimana galeri gambar ingin diletakkan. 

Letakkan tag berikut {gallery}jtc1{/gallery} di dalam teks artikel.  

 
10. Save dan refresh laman web.  
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Memasang Modul (Module)  

1. Pergi ke Back-End. Klik pada Extensions > Module Manager  

 
2. Klik New.  

 
3. Kita akan memilih satu Module yang sedia ada di dalam Joomla! core contohnya 

Most Read Content untuk artikel paling popular.  
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4. Untuk membuat module, kita perlu lakukan 4 langkah penting berikut:  
  
a- Nama Module iaitu Title b- Kedudukan Module iaitu 
Position c- Status Module iaitu Published d- Di mana 
Module ingin dipaparkan iaitu Menu Assigment  
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5.   Save  Refresh laman web.    
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Keselamatan Joomla!  

1. Adakah Joomla! selamat?   
Isu keselamatan Joomla! menjadi topik yang kerap diperkatakan. Sebenarnya tiada 
satu pun sistem di dunia yang  boleh dijamin 100% selamat. Sebenarnya ia 
bergantung kepada bagaimana kita menjaga keselamatan sistem tersebut.   
  
Contoh, kenderaan atau rumah kita sendiri. Adakah kita boleh menjamin ianya 100% 
selamat? Sudah tenti ia bergantung kepada langkah-langkah proaktif yang kita 
lakukan dari masa ke semasa untuk menjamin ianya selamat dari pencerobohan / 
kecurian.  
  
Begitu jugalah dengan Joomla!. Sebenarnya Joomla! adalah satu sistem yang kerap di 
pertingkat upaya ciri-ciri keselamatannya oleh komuniti Joomla!.  
  
Pihak komuniti Joomla! akan selalu meningkatkan tahap keselamatan Joomla! 
melalui info-info terkini atau newsletter yang diberikan pada laman web rasmi  
Joomla.org  
  
Oleh itu, adalah penting untuk anda sentiasa peka terhadap apa juga isu-isu 
keselamatan terbaru yang dihebahkan pada web rasmi Joomla.org.  
  
Maklumat lengkap berkenaan keselamatan Joomla boleh didapati di laman ini: 
http://docs.joomla.org/Security atau 
http://docs.joomla.org/Joomla_Administrators_Security_Checklist  
  
  

2. Namun demikian, kita perlu mengambil langkah-langkah asas dan terpenting berikut 
dalam keselamatan Joomla. Jika ini pun tidak dilakukan, maka usahlah kita berkata 
tentang keselamatan Joomla!  
  
Langkah tersebut adalah:  
  
a- Tidak meletakkan nama id admin untuk login pentadbir (Back-End). Gunakan 

password yang sukar dijangka. Gabungan antara huruf dan angka dan simbol 
adalah password paling selamat.  
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b- Selalu mengemaskini  update patches Joomla! core. Contohnya jika versi 
Joomla! yang digunakan sekarang ialah 3.2 manakala versi terbaru ialah 3.3 maka 
anda perlu mengemaskini dengan kadar segera versi Joomla! terbaru tersebut.  

  
c- Selalu mengemaskini extensions luar yang digunakan. Apa saja extension luar 

yang digunakan di dalam Joomla! core perlu dikemaskini jika terdapat versi 
terbaru pada extensions tersebut.  

  

d- Membuang extensions yang tidak diperlukan lagi. Extensions yang tidak 
digunakan perlu dibuang terus dari Joomla! core anda.  
  

e- Melindungi ruang pentadbir (Back-End) dari di akses oleh umum. Ini boleh 
dilakukan dengan melindungi localhost/latihan3/administrator page.  
  

f- Tidak menggunakan XAMPP untuk production site. XAMPP hanya sesuai untuk 
local site / development sahaja.  Anda boleh menggunakan Ubuntu atau wamp 
untuk production server.   
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Backup dan Restore  

1. Backup adalah satu tugas yang sangat penting bagi memastikan web Joomla! kita 
sentiasa mempunyai maklumat dan data-data terkini. Proses backup sangat penting  
dilakukan apabila web yang dihasilkan akan diletakkan pada production site dan 
apabila ianya telah berfungsi sepenuhnya di live site.  
  
Apabila sesuatu web Joomla! telah dibackup, ianya boleh direstore semula untuk 
mendapatkan web Joomla! terkini jika berlaku sebarang kerosakan pada web 
Joomla! di live site.  
  

2. Untuk melakukan Backup & Restore, kita akan menggunakan Components yang 
dinamakan Akeeba Backup. Anda boleh download fail tersebut di JED.  
  

3. Install fail Akeeba Backup yang telah didownload. Rujuk tajuk install Extensions untuk 
proses installation Extentions.  
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Cara Backup   

1. Setelah Akeeba Backup di install, anda perlu melakukan setting tertentu. Klik pada 
Components > Akeeba Backup  

 
2. Klik pada Accept the mandatory information and apply preferences  
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3. Klik Configuration  

 
4. Pilih ZIP format pada Achiver engine. Klik Save & Close  

 

  
  

  
  

5.   Klik  Backup Now   
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6. Proses backup sedang berlaku. Biarkan saja proses ini sehingga tamat. Tempoh masa 

bergantung kepada saiz web Joomla! anda.  
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8. Fail backup dalam format zip. Download fail tersebut dan simpan sebagai backup.  

  
9. Fail backup seperti di bawah. Ianya dalam format .zip  

  
  

7.   Proses backup selesai.   Klik pada  Manage Backups   untuk mendapatkan fail backup.   
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Cara Restore  

Restore ialah proses mendapatkan semula laman web Joomla! anda seperti mana keadaan 
terakhir ia dibackup. Fail backup .zip anda boleh direstore, ianya tidak perlu diunzipkan.  

Proses restore ini juga adalah sama jika anda ingin memasang satu lagi web Joomla! clone di 
pc atau server yang lain.  
  

1. Pindahkan fail backup .zip ke dalam folder htdocs di web server.   

 
2. Ekstrak (unzip) fail tersebut ke dalam folder. 
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3. Rename fail yang telah diekstrak tersebut.  

 
4. Rename sebagai folder contohnya web asal latihan3 atau apa saja nama folder.  
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5. Buka web browser dan taipkan localhost/latihan3 untuk melakukan proses restore 
Akeeba Backup.  
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Klik Next   

  

  
  

6.   Klik  Next   

  
  



 

58  

  

 
7. Database restoration. Tunggu sehingga selesai. Klik Next Step  
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8. Klik Next  

 
  

  
  

9.   Klik  Remove the installation directory   
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10.   Klik  Visit your site’s front - end.   

  


